Investigating issues with forms/apps connected to Airtable

Incident Report for Zite

Resolved

The issue has been resolved. Our team is investigating the root cause.
Posted Apr 07, 2026 - 01:15 UTC

Investigating

We are currently investigating this issue.
Posted Apr 07, 2026 - 00:56 UTC
This incident affected: Forms (respondent experience).