Slowness submitting certain forms and loading dashboard

Incident Report for Fillout

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 19:06 UTC

Monitoring

A fix has been implemented, and the slowness has stabilized. We are monitoring the results.
Posted Jan 06, 2026 - 18:14 UTC

Update

We are continuing to see slowness, our team is continuing to investigate.
Posted Jan 06, 2026 - 17:06 UTC

Investigating

We are currently investigating this issue.
Posted Jan 06, 2026 - 16:44 UTC
This incident affected: Forms (respondent experience).