Investigating slowness in the Zite dashboard and login

Incident Report for Zite

Resolved

The incident has been resolved, and all affected services are operating normally. We’ll continue to monitor performance to ensure stability. Thank you for your patience while we worked to resolve the issue.
Posted Aug 19, 2026 - 16:04 UTC

Identified

The issue has been identified, and a fix is being implemented.
Posted Aug 19, 2026 - 15:41 UTC

Investigating

We are currently investigating this issue.
Posted Aug 19, 2026 - 15:31 UTC
This incident affected: Form editor, Workspaces, Settings & Admin, and Zite App Editor.