Issue connecting to Microsoft services including Outlook

Incident Report for Fillout

Resolved

This incident has been resolved and Microsoft services are functioning as expected again. We apologize for the inconvenience, our team is investigating the root cause.
Posted Feb 19, 2026 - 13:14 UTC

Investigating

We are currently investigating this issue.
Posted Feb 19, 2026 - 12:55 UTC
This incident affected: Forms (respondent experience).