Slowness submitting certain forms and loading dashboard

Incident Report for Fillout

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 15:28 UTC

Monitoring

Services are recovered, our team is continuing to monitor latency.
Posted Sep 11, 2025 - 14:59 UTC

Investigating

We are currently investigating this issue.
Posted Sep 11, 2025 - 14:49 UTC
This incident affected: Forms (respondent experience) and Form editor.