Email notifications are delayed
Incident Report for Fillout
Resolved
New email notifications are fully operational. Queued email notifications from during the outage are being sent over the next 60 minutes.
Posted Sep 14, 2024 - 16:02 UTC
Investigating
Email notifications from form submissions are delayed. Delayed notifications are queued and will still be sent once the outage is resolved. Our team is investigating.
Posted Sep 14, 2024 - 14:51 UTC
This incident affected: Forms (respondent experience).